Requisitos de WordPress mínimos para usarlo

Requisitos de WordPress mínimos para usarlo

En esta página te explicamos cuáles son los requisitos de WordPress mínimos. Si estás aquí imagino que es por una de los dos siguientes situaciones:

  • Quieres saber los requerimientos para su instalación en un hosting o servidor.
  • Tu web no va del todo bien y puede que sea porque ya no cumples con lo necesario.

Si vienes por el segundo motivo, no desesperes pues es algo habitual. A medida que WordPress avanza y mejora, sube el nivel de los requisitos mínimos para funcionar. Y la mayoría de hostings, aunque ponen a tu disposición las nuevas tecnologías, no te las aplican automáticamente. Lo normal es que tú debas solicitarlas expresamente, ya sea de forma automática o manual.

¿Por qué se funciona así?

Pues porque la mayor parte de las personas que tienen un WordPress, no la tienen al día. Es decir, no tienen su tema y sus plugins actualizados a la última versión. ¿Qué pasaría pues si el hosting aplicara automáticamente los nuevos requisitos mínimos de WordPress? Probablemente la web petaría.

Sea cual sea tu caso, echa un vistazo a continuación pues te listamos los requisitos para WordPress y te los explicamos uno a uno. Por si fuera poco, también te decimos cuáles son los proveedores de alojamiento web oficiales y te guiamos en el siguiente paso que debes seguir para tener tu web con WordPress.

Estos son los requisitos para WordPress 4.9.7

Te listo rápidamente los requisitos necesarios para que WordPress funcione:

  • PHP versión 7.2 o superior
  • MySQL versión 5.6 o superior
  • Certificado SSL
  • mod_rewrite para URLs amigables
¿Te has quedado a cuadros? ¿No entiendes qué significa cada cosa? Don’t worry que ahora te los explico uno a uno con más detalle. Lo hago de una forma informal, sin tecnicismos, para que la explicación te resulte lo más útil posible.
 

PHP 7.2 o superior

PHP es simple y llanamente un lenguaje de programación. Su particularidad es que se centra en generar contenido dinámico. ¿Qué diferencia el contenido dinámico del estático?

El contenido estático es aquél que permanece invariable y no importa quién lo visualiza ni cuándo lo hace. Por ejemplo, una página de política de privacidad es estática.

En cambio, el contenido dinámico sí varía. Imagina casi cualquier periódico digital. Seguramente lo que veas en su web dependa de si eres un visitante o un suscriptor de pago. Y la web también varía a lo largo del día cada vez que añaden nuevas notícias.

Es para esto último que el PHP resulta muy útil. Y lo lleva haciendo desde hace un montón pues este lenguaje de programación vió la luz en 1995. Un par de referencias de webs que utilizan PHP: Wikipedia y Facebook.

Así pues, uno de los requisitos de WordPress es que la versión de PHP sea al menos la 7.2. ¿Por qué? Así tu web se aprovechará de todas las mejoras de rendimiento y de seguridad que se han ido implementando en PHP.

¿Qué pasa si tu versión PHP es inferior?

No sería extraño pues este es el requerimiento que menos se cumple. Lo primero es que debes tener sí o sí al menos la versión 5.2.4. Si incluso es inferior a ésta, olvídate de tener una web con WordPress. De todas formas, aunque estés entre la 5.2.4 y la 7.2, te estarás exponiendo a problemas de seguridad.

MySQL 5.6 o superior

MySQL es el sistema que permite gestionar la base de datos de tu web. La base de datos es donde se almacena toda la información que generas: páginas, entradas de blog, usuarios, etc. De esta forma, PHP le pide un dato a MySQL, éste lo busca en la base de datos y se lo devuelve.

Al igual que con PHP, WordPress aprovecha siempre las oportunidades que ofrece la última versión de MySQL. Así pues, lo lógico es que tú también la utilices.

La versión mínima de MySQL que debes utilizar es la 5.0. Por debajo, olvídate. Entre 5.0 y 5.2, no estarás aprovechando el potencial al máximo.

Certificado SSL de seguridad

Hoy en día, tu web debe ser segura. Y ello significa que la transferencia de datos entre tu web (servidor) y el dispositivo de tus visitantes debe estar protegida. ¿Cómo? Con un certificado SSL.

El certificado SSL es uno de los requisitos de WordPress. Si no lo tienes, tu web se marcará como insegura.
El certificado SSL es uno de los requisitos de WordPress. Si no lo tienes, tu web se marcará como insegura.

Tienes certificados SSL de pago pero existe también uno gratuito y ampliamente utilizado y respaldado: Let’s Encrypt.

Módulo mod_rewrite: el requisito de WordPress más “eing?”

Este requisito de WordPress es técnico. Normal que te líes.

Empezaré diciéndote que un servidor (la máquina física en la que al final está alojada tu web) necesita de un software o programa para funcionar. Lo más utilizados son Apache y Nginx.

Bien pues cualquiera de estos dos programas tiene la siguiente arquitectura:

  • Un núcleo.
  • Módulos que aportan funcionalidad. Cada módulo hace algo diferente.

Hasta aquí bien, ¿verdad?

Bien, pues este requisito te pide un módulo en concreto llamado mod_rewrite. ¿Qué es lo que permite? Que las URLs de las páginas de tu web sean amigables.

Ejemplo de URL amigable: https://srmomo.com/requisitos-de-wordpress-minimos/
Ejemplo de URL no amigable: https://srmomo.com/?p=123sdf564g

Como ves, y aunque sea algo con nombres raros, el mod_rewrite es un requisito de WordPress indispensable.

Alojamientos recomendados oficialmente y que cumplen con los requisitos para usar WordPress

A continuación puedes ver los tres proveedores de hosting que WordPress recomienda de forma oficial.

Los tres cumplen con los requisitos mínimos de WordPress pero tan sólo uno de ellos tiene una atención al cliente en español y desde España.

Imagotipo de Bluehost

Bluehost

Fue el primer hosting recomendado por WordPress de forma oficial.

Imagotipo de SiteGround

SiteGround

Es el que nosotros mismos utilizamos y recomendamos. Soporte gratis y en español.

DreamHost

Hosting enfocado a dar un servicio de calidad superior. Lógicamente se paga.

Como puedes imaginarte, existen muchísimos más proveedores de alojamiento web. Tanto a nivel internacional como español.

Pregunta a tu hosting si cumple con los requisitos de instalación de WordPress

Puede darse el caso en el que sencillamente no tengas ni idea de si el hosting que estás mirando cumple o no con los requisitos técnicos. O puede que ya tengas uno contratado pero estés en las mismas.

¿Qué puedes hacer entonces?

Pues hazles llegar un email con el siguiente mensaje que te facilito:

Hola!

Quisiera conocer si este hosting es cumple con los requisitos de WordPress necesarios para que funcione bien.
Son los siguientes:

  • PHP 7.2 o superior.
  • MySQL 5.6 o superior.
  • Compatibilidad con HTTPS. Posibilidad de instalar un certificado SSL.
  • Módulo mod_rewrite en Apache o Nginx

Por último, quisiera saber si ofrecéis el certificado SSL gratuito Let's Encrypt.

Quedo a la espera de vuestra respuesta. ¡Gracias!

Ya conoces los requisitos de WordPress 4.9.7: ¿cuál es el siguiente paso?

A lo largo de esta página has aprendido cuáles son los requisitos mínimos de WordPress. No sólo eso, también entiendes de qué van y por lo tanto la importancia de tener un buen hosting WordPress para tu web.

¿Qué debes hacer ahora? Pues es fácil: ¡ponerte manos a la obra!

En esta super entrada de blog te explico paso a paso cómo instalar WordPress.

Requisitos de WordPress mínimos para usarlo
Votar es valorar 🙂